【NGAF】WMIC process abnormal causing the authentication failure and high memory usage
Issue Description
WMIC process abnormal causing the authentication failure and high memory usage
Error/Warning Information
WMIC process having high memory usage and ADSSO recent users column is show as 0
Handling Process
-
Perform checking at web ui at Domain SSO, found recent users count is zero.
-
Checked over backend, found available memory is dropping every second.
-
Checked with "ps" command, found wmic process is occupying many memory resource.
-
Tried to kill wmic process and the memory back to normal usage, however it will retake the memory again after the process is restarted.
-
If did not kill the wmic process, it will cause device overloaded and not responding.
Root Cause
if recent 1 hour did not retrieve any new user online, NGAF will start retrieve the user record starting with RecordNumber > 0 where it will retrieve all the user logon logs from AD server and lead to memory consumption peak up suddenly.
Solution
Apply KB-AF-20211230-authWmicFix-AF8.0.23