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[AF] Rule base upgrade failed: Front-end device limitation

Problem Description

AF is deployed in the intranet in routing mode. The rule base cannot be updated, but the upgrade server test is successful.

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Process——

  1. Check AF Interfaces and IP configuration

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  2. Test the connectivity of the server.

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    Click [Update Now] and find that it is still the same

  3. Download log details for analysis

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    Click [Logs Details], download the rule base update log to your local computer, and open it with notepad++ for analysis.
    Through log file analysis, it is found that the rule base file downloaded from Services server to the local computer does not match the md5 of the rule base file on the server, indicating that the rule base file downloaded to the local computer is incorrect.


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  1. I suspected that the library file downloaded to the local computer was incorrect due to Network reasons. I changed the server and updated it again, but the same thing happened. I checked the entire Network environment and found that there was a cache device at the exit. I cancelled the cache control over the AF IP, and then the update was normal.

Root cause

There is a cache device control in the AF external network port direction, which causes the rule base file to be updated abnormally

solution

Cancel the control of the AF Interfaces IP by Network front-end device

Original Link

https://support.sangfor.com.cn/cases/list?product_id=13&type=1&category_id=302&isOpen=true