Table of Contents
< All Topics
Print

[Hardware Troubleshooting] PMC RAID card Mon hard disk that reports an io error, causing the device to crash.

Problem Description

The RAID card is a PMC RAID card, Model PM8222, PM8204
Downtime screenshots

solution

  1. Enter the /sf/log/kdump directory and View whether a downtime log is generated. If so, View whether the downtime log Yes Mon same as the downtime screenshot. FirstYes Mon hard disk io error Mon reported, and then there is a kernel stack line pointing to the RAID card driver smartpqi, stepping on a null pointer BUG. Yes, check the hard disk smart that reports an error. If there is an abnormality, return the disk and upgrade the RAID card. If the hard disk Connected, upgrade the RAID card to the latest Version.
  2. If None downtime Logs, View IPM Logs to see if there is a hardware error, and check the kernel Logs and MCE Logs View if there is a hardware error. If there is, return the corresponding parts for repair. None, contact the corresponding product line R&D for investigation.
    Cause:
    Io timeout causes driver Error, steps on a null pointer, and causes device downtime. The firmware AND driver Version do not match. The manufacturer recommends upgrading the driver to version 2.1.10-020 and coordinating with the corresponding product line R&D for processing.

Original Link

https://support.sangfor.com.cn/cases/list?product_id=156&type=1&category_id=22688&isOpen=true