[ASEC] aSEC VM/Virtual Machine Snapshot Failed
Problem Description
aSEC has security protection enabled, and VM has security components installed. The following scenarios may cause Take Snapshot
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When a ransomware incident occurs or a malicious damage incident is reported, the background response logic will be triggered. The background will automatically create a suspected ransomware snapshot or malicious damage snapshot for the VM/Virtual Machine Take Snapshot fails.
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VM/Virtual Machine performs emergency recovery for ransomware, and the user fails to proactively create a snapshot to retain the ransomware scene
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VM/Virtual Machine handles a security incident or fixes a vulnerability, the snapshot created proactively fails to handle or fix the vulnerability
Warning Information
none
Effective troubleshooting steps
- Check the prerequisites
– VM HCI cluster where the virtual machine/Virtual Machine Cluster >= 3 node
– Whether the HCI Cluster has created VS storage
– VM the storage location of the virtual machine/Virtual Machine
- Check the HCI Cluster and VS storage status
– Check whether the HCI Cluster status is normal
– Check the VS storage Cluster the HCI cluster to see if it is normal
- Troubleshooting vs. storage capacity
- Check the VS storage capacity on the HCI Cluster to see if it is within the normal snapshot threshold range.
Root Cause
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aSEC snapshots only support Storage Based Snapshot, not disk based snapshot
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The HCI Cluster status or VS storage status is abnormal
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VS storage capacity is insufficient to take snapshots
Solution
- aSEC snapshots only support Storage Based Snapshot, not disk based snapshot. The following prerequisites must be met
– HCI Cluster>=3 node
– Create VS storage
– The storage location of the VM/Virtual Machine is on the VS storage (change the storage location to the VS storage)
- The HCI Cluster status or VS storage status is abnormal
– HCI Cluster status is normal (aSec fails to call the HCI interface due to abnormal status. Try to restore it to normal status or contact HCI technical support for processing)
– The VS storage status is normal (the snapshot fails due to abnormal storage status, please contact VS technical support for processing)
- VS storage capacity is insufficient to take snapshots
– The VS storage capacity is within the threshold range for snapshots (snapshots fail due to insufficient storage capacity, clear and release storage space)
Operation Impact Scope
none
Is this a temporary solution?
none
Suggestions and Conclusion
none
Troubleshooting content
none