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[BA] BA query log stuck — hardware KEY detection failed

Problem Description

environment:
The customer purchased the hyper-convergence-based service and also installed our BA on the hyper-convergence. In the early days of BA 2.0, there was only a hardware KEY, so there were both the hyper-convergence hardware KEY and the BA hardware KEY on the hyper-convergence. Due to problems with BA2.0, it was recently upgraded to BA3.0.4.

Problem phenomenon: When opening a behavior-aware application, it gets stuck on the loading screen and you have to wait for a long time before it can be opened. Sometimes the application cannot even be opened.

Warning Information


898295c9cae79a788d.png (54.98 KB)

Process——

  1. Because the synchronization was stopped for a period of time. Currently, the data of many days has been synchronized continuously, which makes the background work process very busy.
  2. The new version of the data center has opened many new applications, and opening these applications will also occupy a certain amount of work process 2
  3. For the new version of the big scan, due to synchronization reasons, the data center will review the ungenerated intermediate data, and then jump to the previous day's log to continue to complete the unmerged original data and continue to generate the index intermediate table.

Root cause

Before BA checks the serial number each time, it will give priority to reading the hardware KEY. If this reading process is stuck, data reading will be stuck, and there is a possibility that BA's hardware KEY will conflict with the hyper-converged KEY.

solution

Currently, the soft KEY has replaced the hardware KEY, and all third-party hardware KEY interfaces on BA have been removed. Currently the observation is normal.

Suggestions and Conclusion

It is recommended that BA use software KEY authorization in the future.

Original Link

https://support.sangfor.com.cn/cases/list?product_id=22&type=1&category_id=6832&isOpen=true