【NGAF】NGAF Logs Conversion % Stuck After Upgrading From Lower Version To 8.0.39
Issue Description
After upgraded the NGAF from a lower version (e.g., 7.3) to NGAF 8.0.39 or higher version, an alert banner is displayed below the menu navigation bar with the description "database is upgraded and logs are being converted (31%). Logs in monitor may not be complete. Please try again later." but the logs conversion progress is stuck at 31% for hours.
Error/Warning Information

Handling Process
-
Apply KB-AF-20211020-dap_convert_dat_err patch to resolve the issue. (consists of versions 8.0.39 and 8.0.47)
-
The patch can be downloaded from the below URL.
Root Cause
The database mechanism used for the lower version is the MySQL database. When upgrading to a newer version (e.g., 8.0.39 and above), the database mechanism will be upgraded from MySQL to dap database; and the data storage type should also be converted from MySQL to dap data type. Hence, this results in log conversion stuck in some aspects.
Solution
- Refer to the handling process.
Suggestions
If the scenario varies from above or the solution doesn’t work, kindly consult specialist or R&D for further verification.