Table of Contents
< All Topics
Print

【aDesk】A large number of agent Agent error occurred after agent Update

Problem Description

Administrator Console VDC console shows a large number of Agent error and the vdsysprocess.dll File does not exist

1657522205403.png.jpg (711.73 KB)

Warning Information

File vdsysprocess.dll file does not exist. The log detection in the agent does not exist this File

Effective troubleshooting steps

  1. Manually replace the missing File, the agent still has Other Error

    1657522432490.png.jpg (11.59 KB)
    The vdsysprocess module Install Failed, resulting in the corresponding Service not starting.
  2. View Upgrading agent Install and find no Error. The copy vdsysprocess.dll File is executed normally.
  3. Check Install anti-virus Software User environment, View anti-virus Software interception log, and find that the copy vdsysprocess.dll Operation is intercepted, resulting in the failure of the vdsysprocess module InstallFailed

    Snipaste_2022-07-11_14-53-10.png (100.87 KB)

Root cause

Anti-virus Software blocking

solution

Log Out antivirus Software

Original Link

https://support.sangfor.com.cn/cases/list?product_id=26&type=1&category_id=12774&isOpen=true