【aDesk】”Failed to check and Update the control. It may be blocked by the local Firewall and anti-virus Software. Please Close Firewall and anti-virus Software first.”
Problem Description
"Checking and Update controls Failed. This may be blocked by the local Firewall and anti-virus Software. Please Close Firewall and anti-virus software firstSoftware"
The customer customized atrust to pull up the vdi function, Above Connected before. Now a pop-Update Popup of "check and update control" Failed and Resource cannot be accessed.
Warning Information

Effective troubleshooting steps
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The client CSClient still prompts that Role is denied when it is started with Forbidden
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The CSClient permission extraction Service has Stopped. Reset the Service still cannot solve the problem. At present, it seems that None None need for the privilege escalation Process to start SangforUD. If Debug None, try to use the privilege escalation Service start sangforUD.
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Passed dbgview log, it is observed that the loaded sangforUD Yes sangforUD in the %TEMP% directory. Passed adding the execution permissions of the this Log In User Add the %TEMP% directory and the sangforUD below, Log In View VM Connected
Root cause
When Update, the client will pull up sangforUD in the %TEMP% directory instead of sangforUD in the vdi Install directory. At this time, the directory and binary None execution Role.
solution
Add Role.
Operation Impacts Applicable To
Odd PC Client
Is Yes temporary solution?
Yes
Suggestions and Conclusion
When troubleshooting the failure to check and Update controls, the focus should be on the Update, which usually involves Role issues. There are two points to pay attention to.
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Is the vdi client privilege Service SangforSPvdi Connected? The Service may be optimized by antivirus software.
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Pay attention to the logs %appdata%/sangfor/vdi/Log/sangfor…log and dbgview (filter vdi). Logs related and sangforUD will be output here.
Original Link
https://support.sangfor.com.cn/cases/list?product_id=26&type=1&category_id=13311&isOpen=true