[VDI] Shared desktop unable to open remote desktop (mstsc)
Issue Description
After connecting to the shared desktop, the remote desktop (mstsc) does not open and shows no response when clicked.
Handling Process
- Log in to the PC using an administrator account and open regedit.exe.
- If the system is 32-bit, navigate to the following registry path: \HKEY_LOCAL_MACHINE \SOFTWARE \Sangfor \SSL \RemoteAppServer \RemoteAppApiHook \NotAllowProList delete mstsc.exe
- If the system is 64-bit, navigate to this registry path: \HKEY_LOCAL_MACHINE \SOFTWARE \Wow6432Node \Sangfor \SSL \RemoteAppServer \RemoteAppApiHook \NotAllowProList delete mstsc.exe

- After delete mstsc.exe registry, mstsc.exe can be open successfully.
Root Cause
By default, shared desktops have restrictions on mstsc, CMD, and other functions that require administrator rights
Solution
Modify the registry to remove the restriction on mstsc.exe