[VDI] Unable to launch Antivirus program on Shared Desktop
Issue Description
Launching the antivirus program on a shared desktop has no effect. However, when RDP is used to access the server and launch the antivirus, it works fine. We can determine that the program is abnormal when access using VDI shared desktop.
Error/Warning Information
The antivirus program shows as abnormal in the Task Manager on the shared desktop

Handling Process
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In Task Manager, right-click on the process and select ‘Open file location’.

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Try launch the .exe and prompts error.

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Go to Registry and create a new string under the registry path: Computer \HKEY_LOCAL_MACHINE \SOFTWARE \WOW6432Node \Sangfor \SSL \RemoteAppServer \RemoteAppApiHook \NotHookExeName

Note: New string value is the name of the .exe used by the Antivirus program. (.exe extension must be included)
Root Cause
The antivirus program conflicts with the VDI service. Adding the program to the registry whitelist resolves the issue.
Solution
Add all .exe used by the antivirus program into ‘NotHookExeName’ list to avoid any conflicts with VDI service.
